Credential leakage in Jenkins Plug-in for ServiceNow
CVE-2023-3414GHSA-rchx-rvh2-vx5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:servicenow-devops 1.38.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.plugins:servicenow-devops
- Affected
- < 1.38.1
- Fixed in
- 1.38.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rchx-rvh2-vx5j lists affected ranges: Maven io.jenkins.plugins:servicenow-devops >=0 <1.38.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-3414: 0.41% estimated exploitation activity in the next 30 days; percentile 35.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A cross-site request forgery vulnerability exists in versions of the Jenkins Plug-in for ServiceNow DevOps prior to 1.38.1 that, if exploited successfully, could cause the unwanted exposure of sensitive information. To address this issue, apply the 1.38.1 version of the Jenkins plug-in for ServiceNow DevOps on your Jenkins server. No changes are required on your instances of the Now Platform.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rchx-rvh2-vx5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-3414 Advisory: Credential leakage in Jenkins Plug-in for ServiceNow IDs: CVE-2023-3414, GHSA-rchx-rvh2-vx5j Record: https://patchnext.com/advisories/cve-2023-3414 (revision 1, source checked 26 Oct 2026, 16:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:servicenow-devops 1.38.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.plugins:servicenow-devops: affected < 1.38.1; fixed in 1.38.1 ## Suggested inspection (read-only) - Maven io.jenkins.plugins:servicenow-devops: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.plugins:servicenow-devops. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rchx-rvh2-vx5j (GitHub-reviewed advisory GHSA-rchx-rvh2-vx5j lists affected ranges: Maven io.jenkins.plugins:servicenow-devops >=0 <1.38.1) Commands are suggestions: review each one before running it.
Loading voting…