fast-xml-parser vulnerable to Regex Injection via Doctype Entities
CVE-2023-34104GHSA-6w63-h3fj-q4vw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 4.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-xml-parser
- Affected
- >= 4.1.3, < 4.2.4
- Fixed in
- 4.2.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6w63-h3fj-q4vw lists affected ranges: npm fast-xml-parser >=4.1.3 <4.2.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6w63-h3fj-q4vw lists affected ranges: npm fast-xml-parser >=4.1.3 <4.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-34104: 1.13% estimated exploitation activity in the next 30 days; percentile 66.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact "fast-xml-parser" allows special characters in entity names, which are not escaped or sanitized. Since the entity name is used for creating a regex for searching and replacing entities in the XML body, an attacker can abuse it for DoS attacks. By crafting an entity name that results in an intentionally bad performing regex and utilizing it in the entity replacement step of the parser, this can cause the parser to stall for an indefinite amount of time. Patches The problem has been resolved in v4.2.4 Workarounds Avoid using DOCTYPE parsing by processEntities: false option.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6w63-h3fj-q4vw
- Revision 1 · created ·
Published from osv record GHSA-6w63-h3fj-q4vw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34104 Advisory: fast-xml-parser vulnerable to Regex Injection via Doctype Entities IDs: CVE-2023-34104, GHSA-6w63-h3fj-q4vw Record: https://patchnext.com/advisories/cve-2023-34104 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 4.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-xml-parser: affected >= 4.1.3, < 4.2.4; fixed in 4.2.4 ## Suggested inspection (read-only) - `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-xml-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6w63-h3fj-q4vw (OSV record GHSA-6w63-h3fj-q4vw lists affected ranges: npm fast-xml-parser >=4.1.3 <4.2.4 (fixed)) - Verified: https://github.com/advisories/GHSA-6w63-h3fj-q4vw (GitHub-reviewed advisory GHSA-6w63-h3fj-q4vw lists affected ranges: npm fast-xml-parser >=4.1.3 <4.2.4) Commands are suggestions: review each one before running it.
Loading voting…