Skip to content

← Actionable
High, CVSS 7.3

avo vulnerable to Stored XSS (Cross Site Scripting) in html content based fields

CVE-2023-34103GHSA-5cr9-5jx3-2g39

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems avo

    Affected
    <= 2.33.2>= 3.0.0.pre1, <= 3.0.0.pre12
    Fixed in
    2.33.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-34103: 0.56% estimated exploitation activity in the next 30 days; percentile 46.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Some avo fields are vulnerable to XSS when rendering html based content. Details During the analysis of the web application, a rendered field was discovered that did not filter JS / HTML tags in a safe way and can be abused to execute js code on a client side. The trix field uses the trix editor in the backend to edit rich text data which basically operates with html tags. To display the stored data in a rendered view, the HasHTMLAttributes concern is used. This can be exploited by an attacker to store javascript code in any trix field by intercepting the request and modifying the post data, as the trix editor does not allow adding custom html or js tags on the frontend. PoC Adding javascript in the post request which is used when editing a "post" resource (body is declared as a trix field) Successful execution of JS code on live demo environment Impact Unlike non-persistent XSS, persistent XSS does not require a social engineering phase. Victims of this attack do not need to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5cr9-5jx3-2g39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34103

Advisory: avo vulnerable to Stored XSS (Cross Site Scripting) in html content based fields
IDs: CVE-2023-34103, GHSA-5cr9-5jx3-2g39
Record: https://patchnext.com/advisories/cve-2023-34103 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: avo 2.33.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems avo: affected <= 2.33.2; >= 3.0.0.pre1, <= 3.0.0.pre12; fixed in 2.33.3

## Suggested inspection (read-only)
- RubyGems avo: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on avo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5cr9-5jx3-2g39 (GitHub-reviewed advisory GHSA-5cr9-5jx3-2g39 lists affected ranges: RubyGems avo >=0 =3.0.0.pre1 <=3.0.0.pre12)

Commands are suggestions: review each one before running it.

Loading voting…