Skip to content

← Actionable
Medium, CVSS 6.5

Kyverno resource with a deletionTimestamp may allow policy circumvention

CVE-2023-34091GHSA-hq4m-4948-64cc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kyverno/kyverno 1.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-34091: 0.50% estimated exploitation activity in the next 30 days; percentile 42.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In versions of Kyverno prior to 1.10.0, resources which have the deletionTimestamp field defined can bypass validate, generate, or mutate-existing policies, even in cases where the validationFailureAction field is set to Enforce. This situation occurs as resources pending deletion were being consciously exempted by Kyverno, as a way to reduce processing load as policies are typically not applied to objects which are being deleted. However, this could potentially result in allowing a malicious user to leverage the Kubernetes finalizers feature by setting a finalizer which causes the Kubernetes API server to set the deletionTimestamp and then not completing the delete operation as a way to explicitly to bypass a Kyverno policy. Note that this is not applicable to Kubernetes Pods but, as an example, a Kubernetes Service resource can be manipulated using an indefinite finalizer to bypass policies. Patches This is resolved in Kyverno 1.10.0. Workarounds There is no known…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hq4m-4948-64cc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34091

Advisory: Kyverno resource with a deletionTimestamp may allow policy circumvention
IDs: CVE-2023-34091, GHSA-hq4m-4948-64cc
Record: https://patchnext.com/advisories/cve-2023-34091 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kyverno/kyverno 1.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kyverno/kyverno: affected < 1.10.0; fixed in 1.10.0

## Suggested inspection (read-only)
- Go github.com/kyverno/kyverno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kyverno/kyverno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hq4m-4948-64cc (GitHub-reviewed advisory GHSA-hq4m-4948-64cc lists affected ranges: Go github.com/kyverno/kyverno >=0 <1.10.0)

Commands are suggestions: review each one before running it.

Loading voting…