Skip to content

← Actionable
High, CVSS 7.5

Decidim vulnerable to sensitive data disclosure

CVE-2023-34090GHSA-jm79-9pm4-vrw9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim 0.27.3; decidim-meetings 0.27.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems decidim

    Affected
    >= 0.27.0, < 0.27.3
    Fixed in
    0.27.3
  • RubyGems decidim-meetings

    Affected
    >= 0.27.0, < 0.27.3
    Fixed in
    0.27.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-34090: 1.26% estimated exploitation activity in the next 30 days; percentile 69.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Note: added the actual report as a comment. Summary Decidim, a platform for digital citizen participation, uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table). Impact This issue may lead to Sensitive Data Disclosure. Patches The problem was patched in v0.27.3. Workarounds Disable or unpublish all meetings components from your application.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jm79-9pm4-vrw9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34090

Advisory: Decidim vulnerable to sensitive data disclosure
IDs: CVE-2023-34090, GHSA-jm79-9pm4-vrw9
Record: https://patchnext.com/advisories/cve-2023-34090 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: decidim 0.27.3; decidim-meetings 0.27.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems decidim: affected >= 0.27.0, < 0.27.3; fixed in 0.27.3
- RubyGems decidim-meetings: affected >= 0.27.0, < 0.27.3; fixed in 0.27.3

## Suggested inspection (read-only)
- RubyGems decidim: check the installed version with your package manager.
- RubyGems decidim-meetings: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on decidim, decidim-meetings.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jm79-9pm4-vrw9 (GitHub-reviewed advisory GHSA-jm79-9pm4-vrw9 lists affected ranges: RubyGems decidim >=0.27.0 =0.27.0 <0.27.3)

Commands are suggestions: review each one before running it.

Loading voting…