Reactor Netty HTTP Server denial of service vulnerability
CVE-2023-34054GHSA-q24v-hpg3-v3jp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.projectreactor.netty:reactor-netty-core 1.1.13, 1.0.39), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.projectreactor.netty:reactor-netty-core
- Affected
- >= 1.1.0, < 1.1.13>= 1.0.0, < 1.0.39
- Fixed in
- 1.0.39, 1.1.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q24v-hpg3-v3jp lists affected ranges: Maven io.projectreactor.netty:reactor-netty-core >=1.1.0 =1.0.0 <1.0.39
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-34054: 0.91% estimated exploitation activity in the next 30 days; percentile 60.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable if Reactor Netty HTTP Server built-in integration with Micrometer is enabled.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q24v-hpg3-v3jp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34054 Advisory: Reactor Netty HTTP Server denial of service vulnerability IDs: CVE-2023-34054, GHSA-q24v-hpg3-v3jp Record: https://patchnext.com/advisories/cve-2023-34054 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.projectreactor.netty:reactor-netty-core 1.1.13, 1.0.39. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.projectreactor.netty:reactor-netty-core: affected >= 1.1.0, < 1.1.13; >= 1.0.0, < 1.0.39; fixed in 1.0.39, 1.1.13 ## Suggested inspection (read-only) - Maven io.projectreactor.netty:reactor-netty-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.projectreactor.netty:reactor-netty-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q24v-hpg3-v3jp (GitHub-reviewed advisory GHSA-q24v-hpg3-v3jp lists affected ranges: Maven io.projectreactor.netty:reactor-netty-core >=1.1.0 =1.0.0 <1.0.39) Commands are suggestions: review each one before running it.
Loading voting…