Spring-Kafka has Java Deserialization vulnerability When Improperly Configured
CVE-2023-34040GHSA-crqf-q9fp-hwjw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.kafka:spring-kafka 3.0.10, 2.9.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.kafka:spring-kafka
- Affected
- >= 3.0.0, < 3.0.10>= 2.8.1, < 2.9.11
- Fixed in
- 3.0.10, 2.9.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-crqf-q9fp-hwjw lists affected ranges: Maven org.springframework.kafka:spring-kafka >=3.0.0 =2.8.1 <2.9.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-34040: 2.09% estimated exploitation activity in the next 30 days; percentile 81.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Spring for Apache Kafka 3.0.9 and earlier and versions 2.9.10 and earlier, a possible deserialization attack vector existed, but only if unusual configuration was applied. An attacker would have to construct a malicious serialized object in one of the deserialization exception record headers. Specifically, an application is vulnerable when all of the following are true: The user does not configure an ErrorHandlingDeserializer for the key and/or value of the record The user explicitly sets container properties checkDeserExWhenKeyNull and/or checkDeserExWhenValueNull container properties to true. The user allows untrusted sources to publish to a Kafka topic By default, these properties are false, and the container only attempts to deserialize the headers if an ErrorHandlingDeserializer is configured. The ErrorHandlingDeserializer prevents the vulnerability by removing any such malicious headers before processing the record.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-crqf-q9fp-hwjw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34040 Advisory: Spring-Kafka has Java Deserialization vulnerability When Improperly Configured IDs: CVE-2023-34040, GHSA-crqf-q9fp-hwjw Record: https://patchnext.com/advisories/cve-2023-34040 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.kafka:spring-kafka 3.0.10, 2.9.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.kafka:spring-kafka: affected >= 3.0.0, < 3.0.10; >= 2.8.1, < 2.9.11; fixed in 3.0.10, 2.9.11 ## Suggested inspection (read-only) - Maven org.springframework.kafka:spring-kafka: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.kafka:spring-kafka. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-crqf-q9fp-hwjw (GitHub-reviewed advisory GHSA-crqf-q9fp-hwjw lists affected ranges: Maven org.springframework.kafka:spring-kafka >=3.0.0 =2.8.1 <2.9.11) Commands are suggestions: review each one before running it.
Loading voting…