Spring Security's authorization rules can be misconfigured when using multiple servlets
CVE-2023-34035GHSA-4vpr-xfrp-cj64
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-config 6.1.2, 6.0.5, 5.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-config
- Affected
- >= 5.8.0, < 5.8.5>= 6.0.0, < 6.0.5>= 6.1.0, < 6.1.2
- Fixed in
- 5.8.5, 6.1.2, 6.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4vpr-xfrp-cj64 lists affected ranges: Maven org.springframework.security:spring-security-config >=5.8.0 =6.0.0 =6.1.0 <6.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2023-34035: 0.66% estimated exploitation activity in the next 30 days; percentile 51.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2 could be susceptible to authorization rule misconfiguration if the application uses requestMatchers(String) and multiple servlets, one of them being Spring MVC’s DispatcherServlet. (DispatcherServlet is a Spring MVC component that maps HTTP endpoints to methods on @Controller-annotated classes.) Specifically, an application is vulnerable when all of the following are true: Spring MVC is on the classpath Spring Security is securing more than one servlet in a single application (one of them being Spring MVC’s DispatcherServlet) The application uses requestMatchers(String) to refer to endpoints that are not Spring MVC endpoints An application is not vulnerable if any of the following is true: The application does not have Spring MVC on the classpath The application secures no servlets other than Spring MVC’s DispatcherServlet The application uses requestMatchers(String) only for Spring MVC endpoints
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4vpr-xfrp-cj64
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34035 Advisory: Spring Security's authorization rules can be misconfigured when using multiple servlets IDs: CVE-2023-34035, GHSA-4vpr-xfrp-cj64 Record: https://patchnext.com/advisories/cve-2023-34035 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-config 6.1.2, 6.0.5, 5.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-config: affected >= 5.8.0, < 5.8.5; >= 6.0.0, < 6.0.5; >= 6.1.0, < 6.1.2; fixed in 5.8.5, 6.1.2, 6.0.5 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-config: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-config. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4vpr-xfrp-cj64 (GitHub-reviewed advisory GHSA-4vpr-xfrp-cj64 lists affected ranges: Maven org.springframework.security:spring-security-config >=5.8.0 =6.0.0 =6.1.0 <6.1.2) Commands are suggestions: review each one before running it.
Loading voting…