Skip to content

← Actionable
Critical, CVSS 9.1

Access Control Bypass in Spring Security

CVE-2023-34034GHSA-3h6f-g5f3-gc4w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-config 6.1.2, 6.0.5, 5.8.5, 5.7.10, 5.6.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-3h6f-g5f3-gc4w lists affected ranges: Maven org.springframework.security:spring-security-config >=5.6.0 =5.7.0 =5.8.0 =6.0.0 =6.1.0 <6.1.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-34034: 4.07% estimated exploitation activity in the next 30 days; percentile 90.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Using "" as a pattern in Spring Security configuration for WebFlux creates a mismatch in pattern matching between Spring Security and Spring WebFlux, and the potential for a security bypass.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3h6f-g5f3-gc4w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34034

Advisory: Access Control Bypass in Spring Security
IDs: CVE-2023-34034, GHSA-3h6f-g5f3-gc4w
Record: https://patchnext.com/advisories/cve-2023-34034 (revision 1, source checked 26 Oct 2026, 16:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-config 6.1.2, 6.0.5, 5.8.5, 5.7.10, 5.6.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security:spring-security-config: affected >= 5.6.0, < 5.6.12; >= 5.7.0, < 5.7.10; >= 5.8.0, < 5.8.5; >= 6.0.0, < 6.0.5; >= 6.1.0, < 6.1.2; fixed in 5.8.5, 5.7.10, 6.1.2, 5.6.12, 6.0.5

## Suggested inspection (read-only)
- Maven org.springframework.security:spring-security-config: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security:spring-security-config.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3h6f-g5f3-gc4w (GitHub-reviewed advisory GHSA-3h6f-g5f3-gc4w lists affected ranges: Maven org.springframework.security:spring-security-config >=5.6.0 =5.7.0 =5.8.0 =6.0.0 =6.1.0 <6.1.2)

Commands are suggestions: review each one before running it.

Loading voting…