Skip to content

← Actionable
High, CVSS 8.1amended

kiwitcms vulnerable to stored cross-site scripting via unrestricted file upload

CVE-2023-33977GHSA-2fqm-m4r2-fh98

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kiwitcms 12.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI kiwitcms

    Affected
    <= 12.3
    Fixed in
    12.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-33977: 0.87% estimated exploitation activity in the next 30 days; percentile 58.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Kiwi TCMS allows users to upload attachments to test plans, test cases, etc. Earlier versions of Kiwi TCMS had introduced upload validators in order to prevent potentially dangerous files from being uploaded and Content-Security-Policy definition to prevent cross-site-scripting attacks. The upload validation checks were not 100% robust which left the possibility to circumvent them and upload a potentially dangerous file which allows execution of arbitrary JavaScript in the browser. Additionally we've discovered that Nginx's proxypass directive will strip some headers negating protections built into Kiwi TCMS when served behind a reverse proxy. Patches - Improved file upload validation code - Updated Nginx reverse proxy configuration for .tenant.kiwitcms.org Workarounds If serving Kiwi TCMS behind a reverse proxy make sure that additional header values are still passed to the client browser. If they aren't redefine them inside the proxy configuration. See etc/nginx.conf#L66-L68…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2fqm-m4r2-fh98

  2. Revision 1 · created ·

    Published from osv record GHSA-2fqm-m4r2-fh98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-33977

Advisory: kiwitcms vulnerable to stored cross-site scripting via unrestricted file upload
IDs: CVE-2023-33977, GHSA-2fqm-m4r2-fh98
Record: https://patchnext.com/advisories/cve-2023-33977 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kiwitcms 12.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI kiwitcms: affected <= 12.3; fixed in 12.4

## Suggested inspection (read-only)
- `python -m pip show kiwitcms`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kiwitcms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2fqm-m4r2-fh98 (OSV record GHSA-2fqm-m4r2-fh98 lists affected ranges: PyPI kiwitcms >=0 <12.4 (fixed))
- Verified: https://github.com/advisories/GHSA-2fqm-m4r2-fh98 (GitHub-reviewed advisory GHSA-2fqm-m4r2-fh98 lists affected ranges: PyPI kiwitcms >=0 <=12.3)

Commands are suggestions: review each one before running it.

Loading voting…