Skip to content

← Actionable
Medium, CVSS 5.5

Craft CMS stored XSS in review volume

CVE-2023-33196GHSA-cjmm-x9x9-m2w5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 4.4.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 4.0.0-RC1, <= 4.4.6
    Fixed in
    4.4.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2023-33196: 0.65% estimated exploitation activity in the next 30 days; percentile 51.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary XSS can be triggered by review volumes PoC 1. Access setting tab 2. Create new assets 3. In assets name inject payload: "<scriptalert(1337)</script 4. Click Utilities tab 5. Choose all volumes, or volume trigger xss 6. Click Update asset indexes. 7. Wait to assets update success. 8. Progress complete. 9. Click on review button will trigger XSS Root cause Function: index.php?p=admin/actions/asset-indexes/process-indexing-session&v=1680710595770 After loading completed, progess will load: "skippedEntries" and "missingEntries" These parameters is not yet filtered, I just tried "skippedEntries" but I think it will be work with "missingEntries" My reponse: { "session": { "id": 10, "indexedVolumes": { "6": "\"<scriptalert(1337)</script" }, "totalEntries": 2235, "processedEntries": 2235, "cacheRemoteImages": true, "listEmptyFolders": false, "isCli": false, "actionRequired": true, "dateCreated": "Apr 5, 2023, 9:03:16 AM", "skippedEntries": …

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cjmm-x9x9-m2w5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-33196

Advisory: Craft CMS stored XSS in review volume
IDs: CVE-2023-33196, GHSA-cjmm-x9x9-m2w5
Record: https://patchnext.com/advisories/cve-2023-33196 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 4.4.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 4.0.0-RC1, <= 4.4.6; fixed in 4.4.7

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cjmm-x9x9-m2w5 (GitHub-reviewed advisory GHSA-cjmm-x9x9-m2w5 lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 <=4.4.6)

Commands are suggestions: review each one before running it.

Loading voting…