Skip to content

← Actionable
Medium, CVSS 6.1

Craft CMS XSS in RSS widget feed

CVE-2023-33195GHSA-qpgm-gjgf-8c2x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 4.4.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 4.3.0, <= 4.4.5
    Fixed in
    4.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-33195: 0.65% estimated exploitation activity in the next 30 days; percentile 51.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A malformed RSS feed can deliver an XSS payload PoC Create an RSS widget and add the domain https://blog.whitebear.vn/file/rss-xss2.rss The XSS payload will be triggered by the title in tag <item Resolved in https://github.com/craftcms/cms/commit/b77cb3023bed4f4a37c11294c4d319ff9f598e1f

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qpgm-gjgf-8c2x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-33195

Advisory: Craft CMS XSS in RSS widget feed
IDs: CVE-2023-33195, GHSA-qpgm-gjgf-8c2x
Record: https://patchnext.com/advisories/cve-2023-33195 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 4.4.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 4.3.0, <= 4.4.5; fixed in 4.4.6

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qpgm-gjgf-8c2x (GitHub-reviewed advisory GHSA-qpgm-gjgf-8c2x lists affected ranges: Packagist craftcms/cms >=4.3.0 <=4.4.5)

Commands are suggestions: review each one before running it.

Loading voting…