Improper handling of NTS cookie length that could crash the ntpd-rs server
CVE-2023-33192GHSA-qwhm-h7v3-mrjx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ntpd 0.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io ntpd
- Affected
- >= 0.3.0, < 0.3.3
- Fixed in
- 0.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qwhm-h7v3-mrjx lists affected ranges: crates.io ntpd >=0.3.0 <0.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-33192: 0.71% estimated exploitation activity in the next 30 days; percentile 53.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact ntpd-rs does not validate the length of NTS cookies in received NTP packets to the server. An attacker can crash the server by sending a specially crafted NTP packet containing a cookie shorter than what the server expects. The server also crashes when it is not configured to handle NTS packets. ntpd-rs running purely as an ntp client is not affected. Patches The issue was caused by improper slice indexing. The indexing operations were replaced by safer alternatives that do not crash the ntpd-rs server process but instead properly handle the error condition. A patch was released in version 0.3.3 Workarounds ntpd-rs running purely as an ntp client is not affected. By default, ntpd-rs packages are not configured to run as a server. For machines where serving the time is required, there is no known workaround. Users are recommended to upgrade ntpd-rs as soon as possible. References https://github.com/pendulum-project/ntpd-rs/pull/752 We would like to thank @mlichvar for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qwhm-h7v3-mrjx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-33192 Advisory: Improper handling of NTS cookie length that could crash the ntpd-rs server IDs: CVE-2023-33192, GHSA-qwhm-h7v3-mrjx Record: https://patchnext.com/advisories/cve-2023-33192 (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ntpd 0.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io ntpd: affected >= 0.3.0, < 0.3.3; fixed in 0.3.3 ## Suggested inspection (read-only) - crates.io ntpd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ntpd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qwhm-h7v3-mrjx (GitHub-reviewed advisory GHSA-qwhm-h7v3-mrjx lists affected ranges: crates.io ntpd >=0.3.0 <0.3.3) Commands are suggestions: review each one before running it.
Loading voting…