Pomerium vulnerable to Incorrect Authorization with specially crafted requests
CVE-2023-33189GHSA-pvrc-wvj2-f59p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.22.2, 0.21.4, 0.20.1, 0.19.2, 0.18.1, 0.17.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/pomerium/pomerium
- Affected
- >= 0.22.0, < 0.22.2>= 0.21.0, < 0.21.4>= 0.20.0, < 0.20.1>= 0.19.0, < 0.19.2>= 0.18.0, < 0.18.1< 0.17.4
- Fixed in
- 0.21.4, 0.20.1, 0.17.4, 0.22.2, 0.19.2, 0.18.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pvrc-wvj2-f59p lists affected ranges: Go github.com/pomerium/pomerium >=0.22.0 =0.21.0 =0.20.0 =0.19.0 =0.18.0 =0 <0.17.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2023-33189: 0.92% estimated exploitation activity in the next 30 days; percentile 60.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact With specially crafted requests, incorrect authorization decisions may be made by Pomerium. Patches We are releasing patch fixes to address this vulnerability going back to v0.17.X. Please upgrade to: - v0.22.2 - v0.21.4 - v0.20.1 - v0.19.2 - v0.18.1 - v0.17.4 For more information If you have any questions or comments about this advisory: - Open an issue in pomerium/pomerium - Email us at security@pomerium.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pvrc-wvj2-f59p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-33189 Advisory: Pomerium vulnerable to Incorrect Authorization with specially crafted requests IDs: CVE-2023-33189, GHSA-pvrc-wvj2-f59p Record: https://patchnext.com/advisories/cve-2023-33189 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.22.2, 0.21.4, 0.20.1, 0.19.2, 0.18.1, 0.17.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/pomerium/pomerium: affected >= 0.22.0, < 0.22.2; >= 0.21.0, < 0.21.4; >= 0.20.0, < 0.20.1; >= 0.19.0, < 0.19.2; >= 0.18.0, < 0.18.1; < 0.17.4; fixed in 0.21.4, 0.20.1, 0.17.4, 0.22.2, 0.19.2, 0.18.1 ## Suggested inspection (read-only) - Go github.com/pomerium/pomerium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/pomerium/pomerium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pvrc-wvj2-f59p (GitHub-reviewed advisory GHSA-pvrc-wvj2-f59p lists affected ranges: Go github.com/pomerium/pomerium >=0.22.0 =0.21.0 =0.20.0 =0.19.0 =0.18.0 =0 <0.17.4) Commands are suggestions: review each one before running it.
Loading voting…