Jenkins SAML Single Sign On(SSO) Plugin Cross-Site Request Forgery vulnerability
CVE-2023-32991GHSA-xw6j-mq6v-pmv6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:miniorange-saml-sp 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.plugins:miniorange-saml-sp
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xw6j-mq6v-pmv6 lists affected ranges: Maven io.jenkins.plugins:miniorange-saml-sp >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2023-32991: 0.68% estimated exploitation activity in the next 30 days; percentile 52.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins SAML Single Sign On(SSO) Plugin 2.0.2 and earlier does not perform permission checks in multiple HTTP endpoints. This allows attackers with Overall/Read permission to send an HTTP request to an attacker-specified URL and parse the response as XML, or parse a local file on the Jenkins controller as XML. As the plugin does not configure its XML parser to prevent XML external entity (XXE) attacks, attackers can have Jenkins parse a crafted XML response that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Additionally, these HTTP endpoints do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. SAML Single Sign On(SSO) Plugin 2.1.0 requires POST requests and Overall/Administer permission for the affected HTTP endpoints.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xw6j-mq6v-pmv6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32991 Advisory: Jenkins SAML Single Sign On(SSO) Plugin Cross-Site Request Forgery vulnerability IDs: CVE-2023-32991, GHSA-xw6j-mq6v-pmv6 Record: https://patchnext.com/advisories/cve-2023-32991 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:miniorange-saml-sp 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.plugins:miniorange-saml-sp: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Maven io.jenkins.plugins:miniorange-saml-sp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.plugins:miniorange-saml-sp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xw6j-mq6v-pmv6 (GitHub-reviewed advisory GHSA-xw6j-mq6v-pmv6 lists affected ranges: Maven io.jenkins.plugins:miniorange-saml-sp >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…