Jenkins Email Extension Plugin missing permission check
CVE-2023-32979GHSA-6gp4-2f92-j2w5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:email-ext 2.96.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:email-ext
- Affected
- < 2.96.1
- Fixed in
- 2.96.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6gp4-2f92-j2w5 lists affected ranges: Maven org.jenkins-ci.plugins:email-ext >=0 <2.96.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-32979: 0.50% estimated exploitation activity in the next 30 days; percentile 43.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Email Extension Plugin 2.96 and earlier does not perform a permission check in a method implementing form validation. This allows attackers with Overall/Read permission to check for the existence of files in the email-templates/ directory in the Jenkins home directory on the controller file system. This form validation method requires the appropriate permission in Email Extension Plugin 2.96.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6gp4-2f92-j2w5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32979 Advisory: Jenkins Email Extension Plugin missing permission check IDs: CVE-2023-32979, GHSA-6gp4-2f92-j2w5 Record: https://patchnext.com/advisories/cve-2023-32979 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:email-ext 2.96.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:email-ext: affected < 2.96.1; fixed in 2.96.1 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:email-ext: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:email-ext. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6gp4-2f92-j2w5 (GitHub-reviewed advisory GHSA-6gp4-2f92-j2w5 lists affected ranges: Maven org.jenkins-ci.plugins:email-ext >=0 <2.96.1) Commands are suggestions: review each one before running it.
Loading voting…