Skip to content

← Actionable
High, CVSS 7.4amended

Connection confusion in gRPC

CVE-2023-32731GHSA-cfgp-2977-2fmm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.grpc:grpc-protobuf 1.54.2, 1.53.1; grpc 1.54.2, 1.53.1; grpcio 1.54.2, 1.53.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.grpc:grpc-protobuf

    Affected
    >= 1.53.0, < 1.53.1>= 1.54.0, < 1.54.2
    Fixed in
    1.53.1, 1.54.2
  • RubyGems grpc

    Affected
    >= 1.53.0, < 1.53.1>= 1.54.0, < 1.54.2
    Fixed in
    1.53.1, 1.54.2
  • PyPI grpcio

    Affected
    >= 1.53.0, < 1.53.1>= 1.54.0, < 1.54.2
    Fixed in
    1.53.1, 1.54.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
  • CVE-2023-32731: 0.50% estimated exploitation activity in the next 30 days; percentile 42.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When gRPC HTTP2 stack raised a header size exceeded error, it skipped parsing the rest of the HPACK frame. This caused any HPACK table mutations to also be skipped, resulting in a desynchronization of HPACK tables between sender and receiver. If leveraged, say, between a proxy and a backend, this could lead to requests from the proxy being interpreted as containing headers from different proxy clients - leading to an information leak that can be used for privilege escalation or data exfiltration.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cfgp-2977-2fmm

  2. Revision 1 · created ·

    Published from osv record GHSA-cfgp-2977-2fmm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32731

Advisory: Connection confusion in gRPC
IDs: CVE-2023-32731, GHSA-cfgp-2977-2fmm
Record: https://patchnext.com/advisories/cve-2023-32731 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.grpc:grpc-protobuf 1.54.2, 1.53.1; grpc 1.54.2, 1.53.1; grpcio 1.54.2, 1.53.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.grpc:grpc-protobuf: affected >= 1.53.0, < 1.53.1; >= 1.54.0, < 1.54.2; fixed in 1.53.1, 1.54.2
- RubyGems grpc: affected >= 1.53.0, < 1.53.1; >= 1.54.0, < 1.54.2; fixed in 1.53.1, 1.54.2
- PyPI grpcio: affected >= 1.53.0, < 1.53.1; >= 1.54.0, < 1.54.2; fixed in 1.53.1, 1.54.2

## Suggested inspection (read-only)
- Maven io.grpc:grpc-protobuf: check the installed version with your package manager.
- RubyGems grpc: check the installed version with your package manager.
- `python -m pip show grpcio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.grpc:grpc-protobuf, grpc, grpcio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cfgp-2977-2fmm (OSV record GHSA-cfgp-2977-2fmm lists affected ranges: Maven io.grpc:grpc-protobuf >=1.53.0 =1.54.0 =1.53.0 =1.54.0 =1.53.0 =1.54.0 <1.54.2 (fixed))
- Verified: https://github.com/advisories/GHSA-cfgp-2977-2fmm (GitHub-reviewed advisory GHSA-cfgp-2977-2fmm lists affected ranges: Maven io.grpc:grpc-protobuf >=1.53.0 =1.54.0 =1.53.0 =1.54.0 =1.53.0 =1.54.0 <1.54.2)

Commands are suggestions: review each one before running it.

Loading voting…