Sqlite-jdbc vulnerable to remote code execution when JDBC url is attacker controlled
CVE-2023-32697GHSA-6phf-6h5g-97j2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xerial:sqlite-jdbc 3.41.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xerial:sqlite-jdbc
- Affected
- >= 3.6.14.1, < 3.41.2.2
- Fixed in
- 3.41.2.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6phf-6h5g-97j2 lists affected ranges: Maven org.xerial:sqlite-jdbc >=3.6.14.1 <3.41.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-32697: 1.60% estimated exploitation activity in the next 30 days; percentile 75.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Sqlite-jdbc addresses a remote code execution vulnerability via JDBC URL. Impacted versions : 3.6.14.1-3.41.2.1 References https://github.com/xerial/sqlite-jdbc/releases/tag/3.41.2.2
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6phf-6h5g-97j2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32697 Advisory: Sqlite-jdbc vulnerable to remote code execution when JDBC url is attacker controlled IDs: CVE-2023-32697, GHSA-6phf-6h5g-97j2 Record: https://patchnext.com/advisories/cve-2023-32697 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xerial:sqlite-jdbc 3.41.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xerial:sqlite-jdbc: affected >= 3.6.14.1, < 3.41.2.2; fixed in 3.41.2.2 ## Suggested inspection (read-only) - Maven org.xerial:sqlite-jdbc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xerial:sqlite-jdbc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6phf-6h5g-97j2 (GitHub-reviewed advisory GHSA-6phf-6h5g-97j2 lists affected ranges: Maven org.xerial:sqlite-jdbc >=3.6.14.1 <3.41.2.2) Commands are suggestions: review each one before running it.
Loading voting…