Skip to content

← Actionable
Medium, CVSS 6.9amended

Insufficient validation when decoding a Socket.IO packet

CVE-2023-32695GHSA-cqmj-92xf-r6r9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (socket.io-parser 4.2.3, 3.4.3, 3.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm socket.io-parser

    Affected
    >= 3.4.0, < 3.4.3>= 4.0.4, < 4.2.3< 3.3.4
    Fixed in
    3.3.4, 4.2.3, 3.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-32695: 1.06% estimated exploitation activity in the next 30 days; percentile 64.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A specially crafted Socket.IO packet can trigger an uncaught exception on the Socket.IO server, thus killing the Node.js process. Patches A fix has been released today (2023/05/22): - https://github.com/socketio/socket.io-parser/commit/3b78117bf6ba7e99d7a5cfc1ba54d0477554a7f3, included in socket.io-parser@4.2.3 - https://github.com/socketio/socket.io-parser/commit/2dc3c92622dad113b8676be06f23b1ed46b02ced, included in socket.io-parser@3.4.3 Another fix has been released for the 3.3.x branch: - https://github.com/socketio/socket.io-parser/commit/ee006607495eca4ec7262ad080dd3a91439a5ba4, included in socket.io-parser@3.3.4 | socket.io version | socket.io-parser version | Needs minor update? | |---------------------|---------------------------------------------------------------------------------------------------------|--------------------------------------| | 4.5.2...latest | ~4.2.0 (ref) | npm audit fix should be sufficient | | 4.1.3...4.5.1 | ~4.1.1 (ref) | Please upgrade to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cqmj-92xf-r6r9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cqmj-92xf-r6r9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32695

Advisory: Insufficient validation when decoding a Socket.IO packet
IDs: CVE-2023-32695, GHSA-cqmj-92xf-r6r9
Record: https://patchnext.com/advisories/cve-2023-32695 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: socket.io-parser 4.2.3, 3.4.3, 3.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm socket.io-parser: affected >= 3.4.0, < 3.4.3; >= 4.0.4, < 4.2.3; < 3.3.4; fixed in 3.3.4, 4.2.3, 3.4.3

## Suggested inspection (read-only)
- `npm ls socket.io-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on socket.io-parser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cqmj-92xf-r6r9 (OSV record GHSA-cqmj-92xf-r6r9 lists affected ranges: npm socket.io-parser >=4.0.4 =3.4.0 =0 <3.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-cqmj-92xf-r6r9 (GitHub-reviewed advisory GHSA-cqmj-92xf-r6r9 lists affected ranges: npm socket.io-parser >=3.4.0 =4.0.4 =0 <3.3.4)

Commands are suggestions: review each one before running it.

Loading voting…