Decidim Cross-site Scripting vulnerability in the external link redirections
CVE-2023-32693GHSA-469h-mqg8-535r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim 0.27.3, 0.26.7; decidim-core 0.27.3, 0.26.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim
- Affected
- >= 0.27.0, < 0.27.3>= 0.25.0, < 0.26.7
- Fixed in
- 0.26.7, 0.27.3
RubyGems decidim-core
- Affected
- >= 0.27.0, < 0.27.3>= 0.25.0, < 0.26.7
- Fixed in
- 0.26.7, 0.27.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-469h-mqg8-535r lists affected ranges: RubyGems decidim-core >=0.27.0 =0.25.0 =0.27.0 =0.25.0 <0.26.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-32693: 0.82% estimated exploitation activity in the next 30 days; percentile 57.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The external link feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. Patches The problem was patched in v0.27.3 and v0.26.7
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-469h-mqg8-535r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32693 Advisory: Decidim Cross-site Scripting vulnerability in the external link redirections IDs: CVE-2023-32693, GHSA-469h-mqg8-535r Record: https://patchnext.com/advisories/cve-2023-32693 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim 0.27.3, 0.26.7; decidim-core 0.27.3, 0.26.7. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim: affected >= 0.27.0, < 0.27.3; >= 0.25.0, < 0.26.7; fixed in 0.26.7, 0.27.3 - RubyGems decidim-core: affected >= 0.27.0, < 0.27.3; >= 0.25.0, < 0.26.7; fixed in 0.26.7, 0.27.3 ## Suggested inspection (read-only) - RubyGems decidim: check the installed version with your package manager. - RubyGems decidim-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim, decidim-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-469h-mqg8-535r (GitHub-reviewed advisory GHSA-469h-mqg8-535r lists affected ranges: RubyGems decidim-core >=0.27.0 =0.25.0 =0.27.0 =0.25.0 <0.26.7) Commands are suggestions: review each one before running it.
Loading voting…