Phishing attack vulnerability by uploading malicious HTML file
CVE-2023-32689GHSA-9prm-jqwx-45x9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 6.1.1, 5.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- < 5.4.4>= 6.0.0, < 6.1.1
- Fixed in
- 6.1.1, 5.4.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9prm-jqwx-45x9 lists affected ranges: npm parse-server >=0 =6.0.0 <6.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9prm-jqwx-45x9 lists affected ranges: npm parse-server >=0 =6.0.0 <6.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-32689: 0.64% estimated exploitation activity in the next 30 days; percentile 50.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Phishing attack vulnerability by uploading malicious files. A malicious user could upload a HTML file to Parse Server via its public API. That HTML file would then be accessible at the internet domain at which Parse Server is hosted. The URL of the the uploaded HTML could be shared for phishing attacks. The HTML page may seem legitimate because it is served under the internet domain where Parse Server is hosted, which may be the same as a company's official website domain. An additional security issue arises when the Parse JavaScript SDK is used. The SDK stores sessions in the internet browser's local storage, which usually restricts data access depending on the internet domain. A malicious HTML file could contain a script that retrieves the user's session token from local storage and then share it with the attacker. Patches The fix adds a new Parse Server option fileUpload.fileExtensions to restrict file upload on Parse Server by file extension. It is recommended to restrict…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9prm-jqwx-45x9
- Revision 1 · created ·
Published from osv record GHSA-9prm-jqwx-45x9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32689 Advisory: Phishing attack vulnerability by uploading malicious HTML file IDs: CVE-2023-32689, GHSA-9prm-jqwx-45x9 Record: https://patchnext.com/advisories/cve-2023-32689 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 6.1.1, 5.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected < 5.4.4; >= 6.0.0, < 6.1.1; fixed in 6.1.1, 5.4.4 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9prm-jqwx-45x9 (OSV record GHSA-9prm-jqwx-45x9 lists affected ranges: npm parse-server >=0 =6.0.0 <6.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9prm-jqwx-45x9 (GitHub-reviewed advisory GHSA-9prm-jqwx-45x9 lists affected ranges: npm parse-server >=0 =6.0.0 <6.1.1) Commands are suggestions: review each one before running it.
Loading voting…