Skip to content

← Actionable
Medium, CVSS 6.1amended

Unintended leak of Proxy-Authorization header in requests

CVE-2023-32681GHSA-j8r2-6x86-q33q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (requests 2.31.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI requests

    Affected
    >= 2.3.0, < 2.31.0
    Fixed in
    2.31.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-32681: 2.97% estimated exploitation activity in the next 30 days; percentile 87.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Since Requests v2.3.0, Requests has been vulnerable to potentially leaking Proxy-Authorization headers to destination servers, specifically during redirects to an HTTPS origin. This is a product of how rebuildproxies is used to recompute and reattach the Proxy-Authorization header to requests when redirected. Note this behavior has only been observed to affect proxied requests when credentials are supplied in the URL user information component (e.g. https://username:password@proxy:8080). Current vulnerable behavior(s): 1. HTTP → HTTPS: leak 2. HTTPS → HTTP: no leak 3. HTTPS → HTTPS: leak 4. HTTP → HTTP: no leak For HTTP connections sent through the proxy, the proxy will identify the header in the request itself and remove it prior to forwarding to the destination server. However when sent over HTTPS, the Proxy-Authorization header must be sent in the CONNECT request as the proxy has no visibility into further tunneled requests. This results in Requests forwarding the header to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j8r2-6x86-q33q

  2. Revision 1 · created ·

    Published from osv record GHSA-j8r2-6x86-q33q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32681

Advisory: Unintended leak of Proxy-Authorization header in requests
IDs: CVE-2023-32681, GHSA-j8r2-6x86-q33q
Record: https://patchnext.com/advisories/cve-2023-32681 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: requests 2.31.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI requests: affected >= 2.3.0, < 2.31.0; fixed in 2.31.0

## Suggested inspection (read-only)
- `python -m pip show requests`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on requests.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j8r2-6x86-q33q (OSV record GHSA-j8r2-6x86-q33q lists affected ranges: PyPI requests >=2.3.0 <2.31.0 (fixed))
- Verified: https://github.com/advisories/GHSA-j8r2-6x86-q33q (GitHub-reviewed advisory GHSA-j8r2-6x86-q33q lists affected ranges: PyPI requests >=2.3.0 <2.31.0)

Commands are suggestions: review each one before running it.

Loading voting…