Craft CMS vulnerable to Remote Code Execution via unrestricted file extension
CVE-2023-32679GHSA-vqxf-r9ph-cc9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 4.4.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 4.0.0, < 4.4.6
- Fixed in
- 4.4.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vqxf-r9ph-cc9c lists affected ranges: Packagist craftcms/cms >=4.0.0 <4.4.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-32679: 1.85% estimated exploitation activity in the next 30 days; percentile 79.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Unrestricted file extension lead to a potential Remote Code Execution (Authenticated, ALLOWADMINCHANGES=true) Details Vulnerability Cause : If the name parameter value is not empty string('') in the View.php's doesTemplateExist() - resolveTemplate() - resolveTemplateInternal() - resolveTemplate() function, it returns directly without extension verification, so that arbitrary extension files are rendered as twig templates (even if they are not extensions set in defaultTemplateExtensions = ['html', 'twig']) When attacker with admin privileges on the DEV or Misconfigured STG, PROD, they can exploit this vulnerability to remote code execution (ALLOWADMINCHANGES=true) PoC Step 1) Create a new filesystem. Base Path: /var/www/html/templates Step 2) Create a new asset volume. Asset Filesystem: template Step 3) Upload poc file( .txt , .js , .json , etc ) with twig template rce payload Step 4) Create a new global set with template layout. The template filename is poc.js Step 5) When…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vqxf-r9ph-cc9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32679 Advisory: Craft CMS vulnerable to Remote Code Execution via unrestricted file extension IDs: CVE-2023-32679, GHSA-vqxf-r9ph-cc9c Record: https://patchnext.com/advisories/cve-2023-32679 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 4.4.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 4.0.0, < 4.4.6; fixed in 4.4.6 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vqxf-r9ph-cc9c (GitHub-reviewed advisory GHSA-vqxf-r9ph-cc9c lists affected ranges: Packagist craftcms/cms >=4.0.0 <4.4.6) Commands are suggestions: review each one before running it.
Loading voting…