Potential for cross-site scripting in PostHog-js
CVE-2023-32325GHSA-8775-5hwv-wr6v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (posthog-js 1.57.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm posthog-js
- Affected
- < 1.57.2
- Fixed in
- 1.57.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8775-5hwv-wr6v lists affected ranges: npm posthog-js >=0 <1.57.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8775-5hwv-wr6v lists affected ranges: npm posthog-js >=0 <1.57.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-32325: 0.43% estimated exploitation activity in the next 30 days; percentile 37.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Potential for cross-site scripting in posthog-js. Patches The problem has been patched in posthog-js version 1.57.2. Workarounds - This isn't an issue for sites that have a Content Security Policy in place. - Using the HTML tracking snippet on PostHog Cloud always guarantees the latest version of the library – in that case no action is required to upgrade to the patched version. References We will publish details of the vulnerability in 30 days as per our security policy.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8775-5hwv-wr6v
- Revision 1 · created ·
Published from osv record GHSA-8775-5hwv-wr6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32325 Advisory: Potential for cross-site scripting in PostHog-js IDs: CVE-2023-32325, GHSA-8775-5hwv-wr6v Record: https://patchnext.com/advisories/cve-2023-32325 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: posthog-js 1.57.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm posthog-js: affected < 1.57.2; fixed in 1.57.2 ## Suggested inspection (read-only) - `npm ls posthog-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on posthog-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8775-5hwv-wr6v (OSV record GHSA-8775-5hwv-wr6v lists affected ranges: npm posthog-js >=0 <1.57.2 (fixed)) - Verified: https://github.com/advisories/GHSA-8775-5hwv-wr6v (GitHub-reviewed advisory GHSA-8775-5hwv-wr6v lists affected ranges: npm posthog-js >=0 <1.57.2) Commands are suggestions: review each one before running it.
Loading voting…