Skip to content

← Actionable
Critical, CVSS 9.8amended

Ckan remote code execution and private information access via crafted resource ids

CVE-2023-32321GHSA-446m-hmmm-hm8m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckan 2.10.1, 2.9.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ckan

    Affected
    < 2.9.9>= 2.10.0, < 2.10.1
    Fixed in
    2.9.9, 2.10.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-32321: 1.68% estimated exploitation activity in the next 30 days; percentile 77.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Specific vulnerabilities: * Arbitrary file write in `resource_create` and `package_update` actions, using the `ResourceUploader` object. Also reachable via `package_create`, `package_revise`, and `package_patch` via calls to `package_update`. * Remote code execution via unsafe pickle loading, via Beaker's session store when configured to use the file session store backend. * Potential DOS due to lack of a length check on the resource id. * Information disclosure: A user with permission to create a resource can access any other resource on the system if they know the id, even if they don't have access to it. * Resource overwrite: A user with permission to create a resource can overwrite any resource if they know the id, even if they don't have access to it.

Impact A user with permissions to create or edit a dataset can upload a resource with a specially crafted id to write the uploaded file in an arbitrary location. This can be leveraged to Remote Code Execution via Beaker's…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-446m-hmmm-hm8m

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-446m-hmmm-hm8m

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-446m-hmmm-hm8m

  4. Revision 1 · created ·

    Published from osv record GHSA-446m-hmmm-hm8m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32321

Advisory: Ckan remote code execution and private information access via crafted resource ids
IDs: CVE-2023-32321, GHSA-446m-hmmm-hm8m
Record: https://patchnext.com/advisories/cve-2023-32321 (revision 4, source checked 28 Oct 2026, 06:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckan 2.10.1, 2.9.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ckan: affected < 2.9.9; >= 2.10.0, < 2.10.1; fixed in 2.9.9, 2.10.1

## Suggested inspection (read-only)
- `python -m pip show ckan`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-446m-hmmm-hm8m (OSV record GHSA-446m-hmmm-hm8m lists affected ranges: PyPI ckan >=0 <2.9.9 (fixed))
- Verified: https://github.com/advisories/GHSA-446m-hmmm-hm8m (GitHub-reviewed advisory GHSA-446m-hmmm-hm8m lists affected ranges: PyPI ckan >=0 =2.10.0 <=2.10.0)
- Verified: https://osv.dev/vulnerability/GHSA-446m-hmmm-hm8m (OSV record GHSA-446m-hmmm-hm8m lists affected ranges: PyPI ckan >=0 =2.10.0 <2.10.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…