Skip to content

← Actionable
High, CVSS 8.6Exploited · CISA KEV

Administration Console authentication bypass in openfire xmppserver

CVE-2023-32315GHSA-gw42-f939-fhvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.igniterealtime.openfire:xmppserver 4.7.5, 4.6.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L/E:H
EPSS
  • CVE-2023-32315: 100.00% estimated exploitation activity in the next 30 days; percentile 99.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An important security issue affects a range of versions of Openfire, the cross-platform real-time collaboration server based on the XMPP protocol that is created by the Ignite Realtime community. Impact Openfire's administrative console (the Admin Console), a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. Cause Path traversal protections were already in place to protect against exactly this kind of attack, but didn’t defend against certain non-standard URL encoding for UTF-16 characters, that were not supported by the embedded webserver that was in use at the time. A later upgrade of the embedded webserver included support for non-standard URL encoding of UTF-16 characters. The path traversal…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gw42-f939-fhvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32315

Advisory: Administration Console authentication bypass in openfire xmppserver
IDs: CVE-2023-32315, GHSA-gw42-f939-fhvm
Record: https://patchnext.com/advisories/cve-2023-32315 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.igniterealtime.openfire:xmppserver 4.7.5, 4.6.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.igniterealtime.openfire:xmppserver: affected >= 3.10.0, < 4.6.8; >= 4.7.0, < 4.7.5; fixed in 4.6.8, 4.7.5

## Suggested inspection (read-only)
- Maven org.igniterealtime.openfire:xmppserver: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.igniterealtime.openfire:xmppserver.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2023-32315 to the Known Exploited Vulnerabilities catalog on 2023-08-24.)
- Verified: https://github.com/advisories/GHSA-gw42-f939-fhvm (GitHub-reviewed advisory GHSA-gw42-f939-fhvm lists affected ranges: Maven org.igniterealtime.openfire:xmppserver >=3.10.0 =4.7.0 <4.7.5)

Commands are suggestions: review each one before running it.

Loading voting…