Skip to content

← Actionable
High, CVSS 7.5amended

Any file can be included with the pymdown-snippets extension

CVE-2023-32309GHSA-jh85-wwv9-24hv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pymdown-extensions 10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-32309: 1.66% estimated exploitation activity in the next 30 days; percentile 76.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Arbitrary file read when using include file syntax. Details By using the syntax --8<--"/etc/passwd" or --8<--"/proc/self/environ" the content of these files will be rendered in the generated documentation. Additionally, a path relative to a specified, allowed base path can also be used to render the content of a file outside the specified base paths: --8<-- "../../../../etc/passwd". Within the Snippets extension, there exists a basepath option but the implementation is vulnerable to Directory Traversal. The vulnerable section exists in getsnippetpath(self, path) lines 155 to 174 in snippets.py. PoC Impact Any readable file on the host where the plugin is executing may have its content exposed. This can impact any use of Snippets that exposes the use of Snippets to external users. It is never recommended to use Snippets to process user-facing, dynamic content. It is designed to process known content on the backend under the control of the host, but if someone were to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jh85-wwv9-24hv

  2. Revision 1 · created ·

    Published from osv record GHSA-jh85-wwv9-24hv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32309

Advisory: Any file can be included with the pymdown-snippets extension
IDs: CVE-2023-32309, GHSA-jh85-wwv9-24hv
Record: https://patchnext.com/advisories/cve-2023-32309 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pymdown-extensions 10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pymdown-extensions: affected >= 1.5, < 10.0; fixed in 10.0

## Suggested inspection (read-only)
- `python -m pip show pymdown-extensions`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pymdown-extensions.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jh85-wwv9-24hv (OSV record GHSA-jh85-wwv9-24hv lists affected ranges: PyPI pymdown-extensions >=1.5 <10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jh85-wwv9-24hv (GitHub-reviewed advisory GHSA-jh85-wwv9-24hv lists affected ranges: PyPI pymdown-extensions >=1.5 <10.0)

Commands are suggestions: review each one before running it.

Loading voting…