Planet's secret file is created with excessive permissions
CVE-2023-32303GHSA-j5fj-rfh6-qj85
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (planet 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI planet
- Affected
- < 2.0.1
- Fixed in
- 2.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j5fj-rfh6-qj85 lists affected ranges: PyPI planet >=0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j5fj-rfh6-qj85 lists affected ranges: PyPI planet >=0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-32303: 0.25% estimated exploitation activity in the next 30 days; percentile 16.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The secret file stores the user's Planet API authentication information. It should only be accessible by the user, but its permissions allowed the user's group and non-group to read the file as well. Validation Check the permissions on the secret file with ls -l ~/.planet.json and ensure that they read as -rw------- Patches d71415a8 Workarounds Set the secret file permissions to only user read/write by hand:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j5fj-rfh6-qj85
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j5fj-rfh6-qj85
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32303 Advisory: Planet's secret file is created with excessive permissions IDs: CVE-2023-32303, GHSA-j5fj-rfh6-qj85 Record: https://patchnext.com/advisories/cve-2023-32303 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: planet 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI planet: affected < 2.0.1; fixed in 2.0.1 ## Suggested inspection (read-only) - `python -m pip show planet`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on planet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j5fj-rfh6-qj85 (OSV record GHSA-j5fj-rfh6-qj85 lists affected ranges: PyPI planet >=0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-j5fj-rfh6-qj85 (GitHub-reviewed advisory GHSA-j5fj-rfh6-qj85 lists affected ranges: PyPI planet >=0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…