Skip to content

← Actionable
High, CVSS 8.0

Steve doesn’t verify a server’s certificate and is susceptible to man-in-the-middle (MitM) attacks

CVE-2023-32198GHSA-95fc-g4gj-mqmx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/steve 0.5.13, 0.4.4, 0.3.3, 0.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/rancher/steve

    Affected
    >= 0.2.0, < 0.2.1>= 0.4.0, < 0.4.4>= 0.5.0, < 0.5.13>= 0.3.0, < 0.3.3
    Fixed in
    0.5.13, 0.4.4, 0.3.3, 0.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-32198: 0.33% estimated exploitation activity in the next 30 days; percentile 26.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability has been identified in Steve where by default it was using an insecure option that did not validate the certificate presented by the remote server while performing a TLS connection. This could allow the execution of a man-in-the-middle (MitM) attack against services using Steve. For example, Rancher relies on Steve as a dependency for its user interface (UI) to proxy requests to Kubernetes clusters. Users who have the permission to create a service in Rancher’s local cluster can take over Rancher’s UI and display their own UI to gather sensitive information. This is only possible when the setting ui-offline-preferred is manually set to remote (by default Rancher sets it to dynamic). This enables further attacks such as cross-site scripting (XSS), or tampering the UI to collect passwords from other users etc. Please consult the associated MITRE ATT&CK - Technique - Adversary-in-the-Middle for further information about this category of attack. Patches Patched…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-95fc-g4gj-mqmx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32198

Advisory: Steve doesn’t verify a server’s certificate and is susceptible to man-in-the-middle (MitM) attacks
IDs: CVE-2023-32198, GHSA-95fc-g4gj-mqmx
Record: https://patchnext.com/advisories/cve-2023-32198 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/steve 0.5.13, 0.4.4, 0.3.3, 0.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/steve: affected >= 0.2.0, < 0.2.1; >= 0.4.0, < 0.4.4; >= 0.5.0, < 0.5.13; >= 0.3.0, < 0.3.3; fixed in 0.5.13, 0.4.4, 0.3.3, 0.2.1

## Suggested inspection (read-only)
- Go github.com/rancher/steve: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/steve.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-95fc-g4gj-mqmx (GitHub-reviewed advisory GHSA-95fc-g4gj-mqmx lists affected ranges: Go github.com/rancher/steve >=0.2.0 =0.4.0 =0.5.0 =0.3.0 <0.3.3)

Commands are suggestions: review each one before running it.

Loading voting…