rke's credentials are stored in the RKE1 Cluster state ConfigMap
CVE-2023-32191GHSA-6gr4-52w6-vmqx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rke 1.5.10, 1.4.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.4.18, < 1.4.19>= 1.5.9, < 1.5.10
- Fixed in
- 1.4.19, 1.5.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6gr4-52w6-vmqx lists affected ranges: Go github.com/rancher/rke >=1.4.18 =1.5.9 <1.5.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-32191: 0.66% estimated exploitation activity in the next 30 days; percentile 51.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When RKE provisions a cluster, it stores the cluster state in a configmap called full-cluster-state inside the kube-system namespace of the cluster itself. This cluster state object contains information used to set up the K8s cluster, which may include the following sensitive data: - RancherKubernetesEngineConfig - RKENodeConfig - SSH username - SSH private key - SSH private key path - RKEConfigServices - ETCDService - External client key - BackupConfig - S3BackupConfig - AWS access key - AWS secret key - KubeAPIService - SecretsEncryptionConfig - K8s encryption configuration (contains encryption keys) - PrivateRegistries - User - Password - ECRCredentialPlugin - AWS access key - AWS secret key - AWS session token - CloudProvider - AzureCloudProvider - AAD client ID - AAD client secret - AAD client cert password - OpenstackCloudProvider - Username - User ID - Password - VsphereCloudProvider - GlobalVsphereOpts - User - Password - VirtualCenterConfig - User - Password -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6gr4-52w6-vmqx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32191 Advisory: rke's credentials are stored in the RKE1 Cluster state ConfigMap IDs: CVE-2023-32191, GHSA-6gr4-52w6-vmqx Record: https://patchnext.com/advisories/cve-2023-32191 (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rke 1.5.10, 1.4.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rke: affected >= 1.4.18, < 1.4.19; >= 1.5.9, < 1.5.10; fixed in 1.4.19, 1.5.10 ## Suggested inspection (read-only) - Go github.com/rancher/rke: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rke. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6gr4-52w6-vmqx (GitHub-reviewed advisory GHSA-6gr4-52w6-vmqx lists affected ranges: Go github.com/rancher/rke >=1.4.18 =1.5.9 <1.5.10) Commands are suggestions: review each one before running it.
Loading voting…