K3s apiserver port is vulnerable to unauthenticated remote denial-of-service (DoS) attack via TLS SAN stuffing attack
CVE-2023-32187GHSA-m4hf-6vgr-75r2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/k3s-io/k3s 1.28.1, 1.27.5, 1.26.8, 1.25.13, 1.24.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.24.17>= 1.25.0, < 1.25.13>= 1.26.0, < 1.26.8>= 1.27.0, < 1.27.5>= 1.28.0, < 1.28.1
- Fixed in
- 1.25.13, 1.24.17, 1.26.8, 1.27.5, 1.28.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m4hf-6vgr-75r2 lists affected ranges: Go github.com/k3s-io/k3s >=0 =1.25.0 =1.26.0 =1.27.0 =1.28.0 <1.28.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-32187: 0.72% estimated exploitation activity in the next 30 days; percentile 54.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An issue was found in K3s where an attacker with network access to K3s servers' apiserver/supervisor port (TCP 6443) can force the TLS server to add entries to the certificate's Subject Alternative Name (SAN) list, through a stuffing attack, until the certificate grows so large that it exceeds the maximum size allowed by TLS client implementations. OpenSSL for example will raise an excessive message size error when this occurs. No authentication is necessary to perform this attack, only the ability to perform a TLS handshake against the apiserver/supervisor port (TCP 6443). Affected servers will continue to operate, but clients (including both external administrative access with kubectl and server or agent nodes) will fail to establish new connections, thus leading to a denial of service (DoS) attack. Remediation Upgrade to a fixed release: - v1.28.1+k3s1 - v1.27.5+k3s1 - v1.26.8+k3s1 - v1.25.13+k3s1 - v1.24.17+k3s1 If you are using K3s 1.27 or earlier, you must also add the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m4hf-6vgr-75r2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32187 Advisory: K3s apiserver port is vulnerable to unauthenticated remote denial-of-service (DoS) attack via TLS SAN stuffing attack IDs: CVE-2023-32187, GHSA-m4hf-6vgr-75r2 Record: https://patchnext.com/advisories/cve-2023-32187 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/k3s-io/k3s 1.28.1, 1.27.5, 1.26.8, 1.25.13, 1.24.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/k3s-io/k3s: affected < 1.24.17; >= 1.25.0, < 1.25.13; >= 1.26.0, < 1.26.8; >= 1.27.0, < 1.27.5; >= 1.28.0, < 1.28.1; fixed in 1.25.13, 1.24.17, 1.26.8, 1.27.5, 1.28.1 ## Suggested inspection (read-only) - Go github.com/k3s-io/k3s: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/k3s-io/k3s. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m4hf-6vgr-75r2 (GitHub-reviewed advisory GHSA-m4hf-6vgr-75r2 lists affected ranges: Go github.com/k3s-io/k3s >=0 =1.25.0 =1.26.0 =1.27.0 =1.28.0 <1.28.1) Commands are suggestions: review each one before running it.
Loading voting…