Skip to content

← Actionable
Low, CVSS 3.1

etcd Key name can be accessed via LeaseTimeToLive API

CVE-2023-32082GHSA-3p4g-rcw5-8298

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/etcd-io/etcd 3.5.9, 3.4.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-32082: 0.74% estimated exploitation activity in the next 30 days; percentile 54.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact LeaseTimeToLive API allows access to key names (not value) associated to a lease when Keys parameter is true, even a user doesn't have read permission to the keys. The impact is limited to a cluster which enables auth (RBAC). Patches < v3.4.26 and < v3.5.9 are affected. Workarounds No. Reporter Yoni Rozenshein

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3p4g-rcw5-8298

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32082

Advisory: etcd Key name can be accessed via LeaseTimeToLive API
IDs: CVE-2023-32082, GHSA-3p4g-rcw5-8298
Record: https://patchnext.com/advisories/cve-2023-32082 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/etcd-io/etcd 3.5.9, 3.4.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/etcd-io/etcd: affected < 3.4.26; >= 3.5.0, < 3.5.9; fixed in 3.5.9, 3.4.26

## Suggested inspection (read-only)
- Go github.com/etcd-io/etcd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/etcd-io/etcd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3p4g-rcw5-8298 (GitHub-reviewed advisory GHSA-3p4g-rcw5-8298 lists affected ranges: Go github.com/etcd-io/etcd >=0 =3.5.0 <3.5.9)

Commands are suggestions: review each one before running it.

Loading voting…