Wings vulnerable to escape to host from installation container
CVE-2023-32080GHSA-p744-4q6p-hvc2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pterodactyl/wings 1.11.6, 1.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/pterodactyl/wings
- Affected
- < 1.7.5>= 1.11.0, < 1.11.6
- Fixed in
- 1.11.6, 1.7.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p744-4q6p-hvc2 lists affected ranges: Go github.com/pterodactyl/wings >=0 =1.11.0 <1.11.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-32080: 0.92% estimated exploitation activity in the next 30 days; percentile 60.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability impacts anyone running the affected versions of Wings. This vulnerability can be used to gain access to the host system running Wings if a user is able to modify an server's install script or the install script executes code supplied by the user (either through environment variables, or commands that execute commands based off of user data). Patches This vulnerability has been resolved in version v1.11.6 of Wings, and has been back-ported to the 1.7 release series in v1.7.5. Anyone running v1.11.x should upgrade to v1.11.6 and anyone running v1.7.x should upgrade to v1.7.5. Workarounds Running Wings with a rootless container runtime may mitigate the severity of any attacks, however the majority of users are using container runtimes that run as root as per our documentation. SELinux may prevent attackers from performing certain operations against the host system, however privileged containers have a lot of freedom even on systems with SELinux enabled. TL;DR:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p744-4q6p-hvc2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32080 Advisory: Wings vulnerable to escape to host from installation container IDs: CVE-2023-32080, GHSA-p744-4q6p-hvc2 Record: https://patchnext.com/advisories/cve-2023-32080 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/pterodactyl/wings 1.11.6, 1.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/pterodactyl/wings: affected < 1.7.5; >= 1.11.0, < 1.11.6; fixed in 1.11.6, 1.7.5 ## Suggested inspection (read-only) - Go github.com/pterodactyl/wings: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/pterodactyl/wings. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p744-4q6p-hvc2 (GitHub-reviewed advisory GHSA-p744-4q6p-hvc2 lists affected ranges: Go github.com/pterodactyl/wings >=0 =1.11.0 <1.11.6) Commands are suggestions: review each one before running it.
Loading voting…