Skip to content

← Actionable
High, CVSS 8.7amended

Vyper vulnerable to incorrect ordering of arguments for kwargs passed to internal calls

CVE-2023-32059GHSA-ph9x-4vc9-m39g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    < 0.3.8
    Fixed in
    0.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-32059: 0.73% estimated exploitation activity in the next 30 days; percentile 54.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Internal calls to internal functions with more than 1 default argument are compiled incorrectly. Depending on the number of arguments provided in the call, the defaults are added not right-to-left, but left-to-right. If the types are incompatible, typechecking is bypassed. In the bar() function in the following code, self.foo(13) is compiled to self.foo(13,12) instead of self.foo(13,1337). note that at the time of publication, the ability to pass kwargs to internal functions is an undocumented feature that does not seem to be widely used. Patches patched in c3e68c302aa6e1429946473769dd1232145822ac Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? References Are there any links users can visit to find out more?

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-ph9x-4vc9-m39g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-ph9x-4vc9-m39g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-32059

Advisory: Vyper vulnerable to incorrect ordering of arguments for kwargs passed to internal calls
IDs: CVE-2023-32059, GHSA-ph9x-4vc9-m39g
Record: https://patchnext.com/advisories/cve-2023-32059 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected < 0.3.8; fixed in 0.3.8

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ph9x-4vc9-m39g (OSV record GHSA-ph9x-4vc9-m39g lists affected ranges: PyPI vyper >=0 <0.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-ph9x-4vc9-m39g (GitHub-reviewed advisory GHSA-ph9x-4vc9-m39g lists affected ranges: PyPI vyper >=0 <0.3.8)

Commands are suggestions: review each one before running it.

Loading voting…