Skip to content

← Actionable
High, CVSS 7.4amended

@fastify/oauth2 vulnerable to Cross Site Request Forgery due to reused Oauth2 state

CVE-2023-31999GHSA-g8x5-p9qc-cf95

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/oauth2 7.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-31999: 0.70% estimated exploitation activity in the next 30 days; percentile 53.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All versions of @fastify/oauth2 used a statically generated state parameter at startup time and were used across all requests for all users. The purpose of the Oauth2 state parameter is to prevent Cross-Site-Request-Forgery attacks. As such, it should be unique per user and should be connected to the user's session in some way that will allow the server to validate it. Patches v7.2.0 changes the default behavior to store the state in a cookie with the http-only and same-site=lax attributes set. The state is now by default generated for every user. Note that this contains a breaking change in the checkStateFunction function, which now accepts the full Request object. Workarounds There are no known workarounds. References Prevent Attacks and Redirect Users with OAuth 2.0 State Parameters

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g8x5-p9qc-cf95

  2. Revision 1 · created ·

    Published from osv record GHSA-g8x5-p9qc-cf95

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-31999

Advisory: @fastify/oauth2 vulnerable to Cross Site Request Forgery due to reused Oauth2 state
IDs: CVE-2023-31999, GHSA-g8x5-p9qc-cf95
Record: https://patchnext.com/advisories/cve-2023-31999 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/oauth2 7.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/oauth2: affected < 7.2.0; fixed in 7.2.0

## Suggested inspection (read-only)
- `npm ls @fastify/oauth2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/oauth2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g8x5-p9qc-cf95 (OSV record GHSA-g8x5-p9qc-cf95 lists affected ranges: npm @fastify/oauth2 >=0 <7.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g8x5-p9qc-cf95 (GitHub-reviewed advisory GHSA-g8x5-p9qc-cf95 lists affected ranges: npm @fastify/oauth2 >=0 <7.2.0)

Commands are suggestions: review each one before running it.

Loading voting…