Skip to content

← Actionable
High, CVSS 7.5

Apache InLong vulnerable to Incorrect Permission Assignment for Critical Resource

CVE-2023-31454GHSA-rf76-whgp-fp56

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.inlong:manager-service 1.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-31454: 1.18% estimated exploitation activity in the next 30 days; percentile 67.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Incorrect Permission Assignment for Critical Resource Vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong from 1.2.0 through 1.6.0. The attacker can bind any cluster, even if he is not the cluster owner. Users are advised to upgrade to Apache InLong 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7947 to solve it.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rf76-whgp-fp56

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-31454

Advisory: Apache InLong vulnerable to Incorrect Permission Assignment for Critical Resource
IDs: CVE-2023-31454, GHSA-rf76-whgp-fp56
Record: https://patchnext.com/advisories/cve-2023-31454 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.inlong:manager-service 1.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.inlong:manager-service: affected >= 1.2.0, < 1.7.0; fixed in 1.7.0

## Suggested inspection (read-only)
- Maven org.apache.inlong:manager-service: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.inlong:manager-service.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rf76-whgp-fp56 (GitHub-reviewed advisory GHSA-rf76-whgp-fp56 lists affected ranges: Maven org.apache.inlong:manager-service >=1.2.0 <1.7.0)

Commands are suggestions: review each one before running it.

Loading voting…