Elasticsearch vulnerable to stack overflow in the search API
CVE-2023-31419GHSA-qwrx-45xf-jjf7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.elasticsearch:elasticsearch 8.9.1, 7.17.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.elasticsearch:elasticsearch
- Affected
- >= 7.0.0, < 7.17.13>= 8.0.0, < 8.9.1
- Fixed in
- 8.9.1, 7.17.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qwrx-45xf-jjf7 lists affected ranges: Maven org.elasticsearch:elasticsearch >=7.0.0 =8.0.0 <8.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-31419: 61.07% estimated exploitation activity in the next 30 days; percentile 99.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was discovered in Elasticsearch affecting the search API that allowed a specially crafted query string to cause a stack overflow and ultimately a denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qwrx-45xf-jjf7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-31419 Advisory: Elasticsearch vulnerable to stack overflow in the search API IDs: CVE-2023-31419, GHSA-qwrx-45xf-jjf7 Record: https://patchnext.com/advisories/cve-2023-31419 (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.elasticsearch:elasticsearch 8.9.1, 7.17.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.elasticsearch:elasticsearch: affected >= 7.0.0, < 7.17.13; >= 8.0.0, < 8.9.1; fixed in 8.9.1, 7.17.13 ## Suggested inspection (read-only) - Maven org.elasticsearch:elasticsearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.elasticsearch:elasticsearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qwrx-45xf-jjf7 (GitHub-reviewed advisory GHSA-qwrx-45xf-jjf7 lists affected ranges: Maven org.elasticsearch:elasticsearch >=7.0.0 =8.0.0 <8.9.1) Commands are suggestions: review each one before running it.
Loading voting…