craftcms/cms vulnerable to cross site scripting in RSS feed widget
CVE-2023-31144GHSA-j4mx-98hw-6rv6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 4.4.4, 3.8.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 3.0.0, <= 3.8.3>= 4.0.0, <= 4.4.3
- Fixed in
- 4.4.4, 3.8.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j4mx-98hw-6rv6 lists affected ranges: Packagist craftcms/cms >=3.0.0 =4.0.0 <=4.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-31144: 0.41% estimated exploitation activity in the next 30 days; percentile 34.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A malformed title in the feed widget of craftcms/cms can deliver an XSS payload. This has been resolved in this commit.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j4mx-98hw-6rv6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-31144 Advisory: craftcms/cms vulnerable to cross site scripting in RSS feed widget IDs: CVE-2023-31144, GHSA-j4mx-98hw-6rv6 Record: https://patchnext.com/advisories/cve-2023-31144 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 4.4.4, 3.8.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 3.0.0, <= 3.8.3; >= 4.0.0, <= 4.4.3; fixed in 4.4.4, 3.8.4 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j4mx-98hw-6rv6 (GitHub-reviewed advisory GHSA-j4mx-98hw-6rv6 lists affected ranges: Packagist craftcms/cms >=3.0.0 =4.0.0 <=4.4.3) Commands are suggestions: review each one before running it.
Loading voting…