Ghost vulnerable to information disclosure of private API fields
CVE-2023-31133GHSA-r97q-ghch-82j9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 5.46.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- < 5.46.1
- Fixed in
- 5.46.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r97q-ghch-82j9 lists affected ranges: npm ghost >=0 <5.46.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r97q-ghch-82j9 lists affected ranges: npm ghost >=0 <5.46.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-31133: 45.71% estimated exploitation activity in the next 30 days; percentile 98.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to a lack of validation when filtering on the public API endpoints, it is possible to reveal private fields via a brute force attack. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version below v5.46.1. Immediate action should be taken to secure your site - see patches and workarounds below. Patches v5.46.1 contains a fix for this issue. Workarounds Add a block for requests to /ghost/api/content/ where the filter query parameter contains password or email. For more information If you have any questions or comments about this advisory: Email us at security@ghost.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r97q-ghch-82j9
- Revision 1 · created ·
Published from osv record GHSA-r97q-ghch-82j9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-31133 Advisory: Ghost vulnerable to information disclosure of private API fields IDs: CVE-2023-31133, GHSA-r97q-ghch-82j9 Record: https://patchnext.com/advisories/cve-2023-31133 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 5.46.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected < 5.46.1; fixed in 5.46.1 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r97q-ghch-82j9 (OSV record GHSA-r97q-ghch-82j9 lists affected ranges: npm ghost >=0 <5.46.1 (fixed)) - Verified: https://github.com/advisories/GHSA-r97q-ghch-82j9 (GitHub-reviewed advisory GHSA-r97q-ghch-82j9 lists affected ranges: npm ghost >=0 <5.46.1) Commands are suggestions: review each one before running it.
Loading voting…