Moodle SQL Injection vulnerability
CVE-2023-30944GHSA-7mmc-22g7-3xq2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.2.0-rc2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- < 4.2.0-rc2
- Fixed in
- 4.2.0-rc2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mmc-22g7-3xq2 lists affected ranges: Packagist moodle/moodle >=0 <4.2.0-rc2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2023-30944: 1.14% estimated exploitation activity in the next 30 days; percentile 66.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in external Wiki method for listing pages. A remote attacker can send a specially crafted request to the affected application and execute limited SQL commands within the application database.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7mmc-22g7-3xq2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30944 Advisory: Moodle SQL Injection vulnerability IDs: CVE-2023-30944, GHSA-7mmc-22g7-3xq2 Record: https://patchnext.com/advisories/cve-2023-30944 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.2.0-rc2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected < 4.2.0-rc2; fixed in 4.2.0-rc2 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7mmc-22g7-3xq2 (GitHub-reviewed advisory GHSA-7mmc-22g7-3xq2 lists affected ranges: Packagist moodle/moodle >=0 <4.2.0-rc2) Commands are suggestions: review each one before running it.
Loading voting…