Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header
CVE-2023-30861GHSA-m2qf-hxjv-5gpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask 2.3.2, 2.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask
- Affected
- >= 2.3.0, < 2.3.2< 2.2.5
- Fixed in
- 2.3.2, 2.2.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m2qf-hxjv-5gpq lists affected ranges: PyPI flask >=2.3.0 =0 <2.2.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m2qf-hxjv-5gpq lists affected ranges: PyPI flask >=2.3.0 =0 <2.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-30861: 1.25% estimated exploitation activity in the next 30 days; percentile 69.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When all of the following conditions are met, a response containing data intended for one client may be cached and subsequently sent by a proxy to other clients. If the proxy also caches Set-Cookie headers, it may send one client's session cookie to other clients. The severity depends on the application's use of the session, and the proxy's behavior regarding cookies. The risk depends on all these conditions being met. 1. The application must be hosted behind a caching proxy that does not strip cookies or ignore responses with cookies. 2. The application sets session.permanent = True. 2. The application does not access or modify the session at any point during a request. 4. SESSIONREFRESHEACHREQUEST is enabled (the default). 5. The application does not set a Cache-Control header to indicate that a page is private or should not be cached. This happens because vulnerable versions of Flask only set the Vary: Cookie header when the session is accessed or modified, not when it is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m2qf-hxjv-5gpq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m2qf-hxjv-5gpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30861 Advisory: Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header IDs: CVE-2023-30861, GHSA-m2qf-hxjv-5gpq Record: https://patchnext.com/advisories/cve-2023-30861 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask 2.3.2, 2.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask: affected >= 2.3.0, < 2.3.2; < 2.2.5; fixed in 2.3.2, 2.2.5 ## Suggested inspection (read-only) - `python -m pip show flask`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m2qf-hxjv-5gpq (OSV record GHSA-m2qf-hxjv-5gpq lists affected ranges: PyPI flask >=2.3.0 =0 <2.2.5 (fixed)) - Verified: https://github.com/advisories/GHSA-m2qf-hxjv-5gpq (GitHub-reviewed advisory GHSA-m2qf-hxjv-5gpq lists affected ranges: PyPI flask >=2.3.0 =0 <2.2.5) Commands are suggestions: review each one before running it.
Loading voting…