Potential HTTP policy bypass when using header rules in Cilium
CVE-2023-30851GHSA-2h44-x2wx-49f4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.13.2, 1.12.9, 1.11.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.11.16>= 1.12.0, < 1.12.9>= 1.13.0, < 1.13.2
- Fixed in
- 1.12.9, 1.11.16, 1.13.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2h44-x2wx-49f4 lists affected ranges: Go github.com/cilium/cilium >=0 =1.12.0 =1.13.0 <1.13.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-30851: 0.66% estimated exploitation activity in the next 30 days; percentile 51.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This issue only impacts users who: - Have a HTTP policy that applies to multiple toEndpoints AND - Have an allow-all rule in place that affects only one of those endpoints In such cases, a wildcard rule will be appended to the set of HTTP rules, which could cause bypass of HTTP policies. Patches This issue has been patched in Cilium 1.11.16, 1.12.9, and 1.13.2. Workarounds Rewrite HTTP rules for each endpoint separately. For example, if the initial rule looks like: It should be rewritten to: Acknowledgements The Cilium community has worked together with members of Isovalent to prepare these mitigations. Special thanks to @jrajahalme for investigating and fixing the issue. For more information If you have any questions or comments about this advisory, please reach out on Slack. As usual, if you think you found a related vulnerability, we strongly encourage you to report security vulnerabilities to our private security mailing list: security@cilium.io - first, before disclosing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2h44-x2wx-49f4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30851 Advisory: Potential HTTP policy bypass when using header rules in Cilium IDs: CVE-2023-30851, GHSA-2h44-x2wx-49f4 Record: https://patchnext.com/advisories/cve-2023-30851 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.13.2, 1.12.9, 1.11.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cilium/cilium: affected < 1.11.16; >= 1.12.0, < 1.12.9; >= 1.13.0, < 1.13.2; fixed in 1.12.9, 1.11.16, 1.13.2 ## Suggested inspection (read-only) - Go github.com/cilium/cilium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cilium/cilium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2h44-x2wx-49f4 (GitHub-reviewed advisory GHSA-2h44-x2wx-49f4 lists affected ranges: Go github.com/cilium/cilium >=0 =1.12.0 =1.13.0 <1.13.2) Commands are suggestions: review each one before running it.
Loading voting…