SQL Injection in Translation Export API
CVE-2023-30849GHSA-xmg8-w465-mr56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 10.5.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- < 10.5.21
- Fixed in
- 10.5.21
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xmg8-w465-mr56 lists affected ranges: Packagist pimcore/pimcore >=0 <10.5.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-30849: 0.79% estimated exploitation activity in the next 30 days; percentile 56.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact SQL injection is a web security vulnerability that allows an attacker to interfere with the queries that an application makes to its database. It generally allows an attacker to view data that they are not normally able to retrieve. This might include data belonging to other users, or any other data that the application itself is able to access. In many cases, an attacker can modify or delete this data, causing persistent changes to the application's content or behavior. In some situations, an attacker can escalate an SQL injection attack to compromise the underlying server or other back-end infrastructure, or perform a denial-of-service attack. It was observed that the reported API endpoint accessible by an authenticated administrator user and is vulnerable to SQL injection via the "filter" GET parameter. The parameter accepts JSON formatted data. The value of JSON key "property" inside "filter" is not sanitized properly and is used in a SQL statement in an unsafe manner,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xmg8-w465-mr56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30849 Advisory: SQL Injection in Translation Export API IDs: CVE-2023-30849, GHSA-xmg8-w465-mr56 Record: https://patchnext.com/advisories/cve-2023-30849 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 10.5.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected < 10.5.21; fixed in 10.5.21 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xmg8-w465-mr56 (GitHub-reviewed advisory GHSA-xmg8-w465-mr56 lists affected ranges: Packagist pimcore/pimcore >=0 <10.5.21) Commands are suggestions: review each one before running it.
Loading voting…