Potential leak of authentication data to 3rd parties
CVE-2023-30846GHSA-558p-m34m-vpmq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typed-rest-client 1.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.8.0
- Fixed in
- 1.8.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-558p-m34m-vpmq lists affected ranges: npm typed-rest-client >=0 <1.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-558p-m34m-vpmq lists affected ranges: npm typed-rest-client >=0 <1.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-30846: 2.22% estimated exploitation activity in the next 30 days; percentile 82.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users of typed-rest-client library version 1.7.3 or lower are vulnerable to leak authentication data to 3rd parties. The flow of the vulnerability is as follows: 1. Send any request with BasicCredentialHandler, BearerCredentialHandler or PersonalAccessTokenCredentialHandler 2. The target host may return a redirection (3xx), with a link to a second host. 3. The next request will use the credentials to authenticate with the second host, by setting the Authorization header. The expected behavior is that the next request will NOT set the Authorization header. Patches The problem was fixed on April 1st 2020. Workarounds There is no workaround. References This is similar to the following issues in nature: 1. HTTP authentication leak in redirects - I used the same solution as CURL did. 2. CVE-2018-1000007.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-558p-m34m-vpmq
- Revision 1 · created ·
Published from osv record GHSA-558p-m34m-vpmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30846 Advisory: Potential leak of authentication data to 3rd parties IDs: CVE-2023-30846, GHSA-558p-m34m-vpmq Record: https://patchnext.com/advisories/cve-2023-30846 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typed-rest-client 1.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm typed-rest-client: affected < 1.8.0; fixed in 1.8.0 ## Suggested inspection (read-only) - `npm ls typed-rest-client --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typed-rest-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-558p-m34m-vpmq (OSV record GHSA-558p-m34m-vpmq lists affected ranges: npm typed-rest-client >=0 <1.8.0 (fixed)) - Verified: https://github.com/advisories/GHSA-558p-m34m-vpmq (GitHub-reviewed advisory GHSA-558p-m34m-vpmq lists affected ranges: npm typed-rest-client >=0 <1.8.0) Commands are suggestions: review each one before running it.
Loading voting…