On a compromised node, the fluid-csi service account can be used to modify node specs
CVE-2023-30840GHSA-93xx-cvmc-9w3v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fluid-cloudnative/fluid 0.8.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/fluid-cloudnative/fluid
- Affected
- >= 0.7.0, < 0.8.6
- Fixed in
- 0.8.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-93xx-cvmc-9w3v lists affected ranges: Go github.com/fluid-cloudnative/fluid >=0.7.0 <0.8.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.0 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-30840: 0.24% estimated exploitation activity in the next 30 days; percentile 14.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If a malicious user gains control of a Kubernetes node running fluid csi pod (controlled by the csi-nodeplugin-fluid node-daemonset), he/she can leverage the fluid-csi service account to modify specs of all the nodes in the cluster. However, since this service account lacks "list node" permissions, the attacker may need to use other techniques to identify vulnerable nodes. Once the attacker identifies and modifies the node specs, he/she can manipulate system-level-privileged components to access all secrets in the cluster or execute pods on other nodes. This allows he/she to elevate privileges beyond the compromised node and potentially gain full privileged access to the whole cluster. To exploit this vulnerability, the attacker can make all other nodes unschedulable (for example, patch node with taints) and wait for system-critical components with high privilege to appear on the compromised node. However, this attack requires two prerequisites: a compromised node and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-93xx-cvmc-9w3v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30840 Advisory: On a compromised node, the fluid-csi service account can be used to modify node specs IDs: CVE-2023-30840, GHSA-93xx-cvmc-9w3v Record: https://patchnext.com/advisories/cve-2023-30840 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/fluid-cloudnative/fluid 0.8.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/fluid-cloudnative/fluid: affected >= 0.7.0, < 0.8.6; fixed in 0.8.6 ## Suggested inspection (read-only) - Go github.com/fluid-cloudnative/fluid: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/fluid-cloudnative/fluid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-93xx-cvmc-9w3v (GitHub-reviewed advisory GHSA-93xx-cvmc-9w3v lists affected ranges: Go github.com/fluid-cloudnative/fluid >=0.7.0 <0.8.6) Commands are suggestions: review each one before running it.
Loading voting…