Skip to content

← Actionable
High, CVSS 8.7amended

Lemur subject to insecure random generation

CVE-2023-30797GHSA-5fqv-mpj8-h7gm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lemur

    Affected
    < 1.3.2
    Fixed in
    1.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-30797: 0.79% estimated exploitation activity in the next 30 days; percentile 56.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Lemur was using insecure random generation for its example configuration file, as well as for some utilities. Impact The potentially affected generated items include: | Configuration item | Config option name (if applicable) | Documentation link (if applicable) | Rotation option | Code reference(s) | | ----------- | ----------- | ----------- | ----------- |----------- | | Flask session secret | SECRETKEY | Flask documentation | Generate a new secret and place in config; all existing sessions will be invalidated | N/A, internal to Flask | | Lemur token secret | LEMURTOKENSECRET | Lemur's configuration documentation | Generate a new secret and place in config; all existing JWTs will be invalidated and must be regenerated (including API keys) | 1, 2 | | Lemur database encryption key | LEMURENCRYPTIONKEYS | Lemur's configuration documentation | A new key can be generated and added to this list, but existing data encrypted with prior keys cannot be re-encrypted unless you write a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5fqv-mpj8-h7gm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5fqv-mpj8-h7gm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-30797

Advisory: Lemur subject to insecure random generation
IDs: CVE-2023-30797, GHSA-5fqv-mpj8-h7gm
Record: https://patchnext.com/advisories/cve-2023-30797 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemur 1.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lemur: affected < 1.3.2; fixed in 1.3.2

## Suggested inspection (read-only)
- `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemur.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5fqv-mpj8-h7gm (OSV record GHSA-5fqv-mpj8-h7gm lists affected ranges: PyPI lemur >=0 <1.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5fqv-mpj8-h7gm (GitHub-reviewed advisory GHSA-5fqv-mpj8-h7gm lists affected ranges: PyPI lemur >=0 <1.3.2)

Commands are suggestions: review each one before running it.

Loading voting…