Nomad ACL Policies without Label are Applied to Unexpected Resources
CVE-2023-3072GHSA-rpvr-38xv-xvxq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/nomad 1.5.6, 1.4.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.7.0, < 1.4.11>= 1.5.0, < 1.5.6
- Fixed in
- 1.5.6, 1.4.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rpvr-38xv-xvxq lists affected ranges: Go github.com/hashicorp/nomad >=0.7.0 =1.5.0 <1.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
- EPSS
- CVE-2023-3072: 0.44% estimated exploitation activity in the next 30 days; percentile 37.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was identified in Nomad, an ACL policy using a block without label may be applied to unexpected resources. This vulnerability, CVE-2023-3072, affects Nomad from 0.7 up to 1.5.6 and 1.4.10 and was fixed in 1.6.0, 1.5.7, and 1.4.11.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rpvr-38xv-xvxq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-3072 Advisory: Nomad ACL Policies without Label are Applied to Unexpected Resources IDs: CVE-2023-3072, GHSA-rpvr-38xv-xvxq Record: https://patchnext.com/advisories/cve-2023-3072 (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/nomad 1.5.6, 1.4.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/nomad: affected >= 0.7.0, < 1.4.11; >= 1.5.0, < 1.5.6; fixed in 1.5.6, 1.4.11 ## Suggested inspection (read-only) - Go github.com/hashicorp/nomad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/nomad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rpvr-38xv-xvxq (GitHub-reviewed advisory GHSA-rpvr-38xv-xvxq lists affected ranges: Go github.com/hashicorp/nomad >=0.7.0 =1.5.0 <1.5.6) Commands are suggestions: review each one before running it.
Loading voting…