Skip to content

← Actionable
High, CVSS 7.8

Apache Cassandra: Privilege escalation when enabling FQL/Audit logs

CVE-2023-30601GHSA-m9p2-j4hg-g373

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cassandra:cassandra-all 4.1.2, 4.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-30601: 0.34% estimated exploitation activity in the next 30 days; percentile 27.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user running Apache Cassandra This issue affects Apache Cassandra: from 4.0.0 through 4.0.9, from 4.1.0 through 4.1.1. WORKAROUND The vulnerability requires nodetool/JMX access to be exploitable, disable access for any non-trusted users. MITIGATION Upgrade to 4.0.10 or 4.1.2 and leave the new FQL/Auditlog configuration property allownodetoolarchivecommand as false.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m9p2-j4hg-g373

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-30601

Advisory: Apache Cassandra: Privilege escalation when enabling FQL/Audit logs
IDs: CVE-2023-30601, GHSA-m9p2-j4hg-g373
Record: https://patchnext.com/advisories/cve-2023-30601 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.cassandra:cassandra-all 4.1.2, 4.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.cassandra:cassandra-all: affected >= 4.1.0, < 4.1.2; >= 4.0.0, < 4.0.10; fixed in 4.1.2, 4.0.10

## Suggested inspection (read-only)
- Maven org.apache.cassandra:cassandra-all: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.cassandra:cassandra-all.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m9p2-j4hg-g373 (GitHub-reviewed advisory GHSA-m9p2-j4hg-g373 lists affected ranges: Maven org.apache.cassandra:cassandra-all >=4.1.0 =4.0.0 <4.0.10)

Commands are suggestions: review each one before running it.

Loading voting…