Arbitrary file read via SQL injection
CVE-2023-30545GHSA-8r4m-5p6p-52rp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/prestashop 8.0.4, 1.7.8.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/prestashop
- Affected
- >= 8.0.0, < 8.0.4< 1.7.8.9
- Fixed in
- 1.7.8.9, 8.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8r4m-5p6p-52rp lists affected ranges: Packagist prestashop/prestashop >=8.0.0 =0 <1.7.8.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-30545: 0.86% estimated exploitation activity in the next 30 days; percentile 58.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It is possible for a user having access to the SQL Manager (Advanced Options - Database) to arbitrary read any file on the Operating system when using SQL function LOADFILE in a SELECT request. So It can access to critical information. Patches The patch will be on PS 8.0.4 and PS 1.7.8.9
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8r4m-5p6p-52rp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30545 Advisory: Arbitrary file read via SQL injection IDs: CVE-2023-30545, GHSA-8r4m-5p6p-52rp Record: https://patchnext.com/advisories/cve-2023-30545 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/prestashop 8.0.4, 1.7.8.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/prestashop: affected >= 8.0.0, < 8.0.4; < 1.7.8.9; fixed in 1.7.8.9, 8.0.4 ## Suggested inspection (read-only) - Packagist prestashop/prestashop: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/prestashop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8r4m-5p6p-52rp (GitHub-reviewed advisory GHSA-8r4m-5p6p-52rp lists affected ranges: Packagist prestashop/prestashop >=8.0.0 =0 <1.7.8.9) Commands are suggestions: review each one before running it.
Loading voting…