kiwi TCMS has possibility for user to update email address to unverified one
CVE-2023-30544GHSA-7x6q-3v3m-cwjg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kiwitcms 12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI kiwitcms
- Affected
- < 12.2
- Fixed in
- 12.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7x6q-3v3m-cwjg lists affected ranges: PyPI kiwitcms >=0 <12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7x6q-3v3m-cwjg lists affected ranges: PyPI kiwitcms >=0 <12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 0.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:N
- EPSS
- CVE-2023-30544: 0.42% estimated exploitation activity in the next 30 days; percentile 36.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In previous versions of Kiwi TCMS users were able to update their email addresses via the "My profile" admin page. This page allowed them to change the email address registered with their account without the ownership verification performed during account registration. Patches With Kiwi TCMS v12.2 or later it is not possible to edit the email field associated with a user account! Workarounds No workaround exists. References Disclosed by @novemberdad.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7x6q-3v3m-cwjg
- Revision 1 · created ·
Published from osv record GHSA-7x6q-3v3m-cwjg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-30544 Advisory: kiwi TCMS has possibility for user to update email address to unverified one IDs: CVE-2023-30544, GHSA-7x6q-3v3m-cwjg Record: https://patchnext.com/advisories/cve-2023-30544 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated (CVSS 0.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kiwitcms 12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI kiwitcms: affected < 12.2; fixed in 12.2 ## Suggested inspection (read-only) - `python -m pip show kiwitcms`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kiwitcms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7x6q-3v3m-cwjg (OSV record GHSA-7x6q-3v3m-cwjg lists affected ranges: PyPI kiwitcms >=0 <12.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7x6q-3v3m-cwjg (GitHub-reviewed advisory GHSA-7x6q-3v3m-cwjg lists affected ranges: PyPI kiwitcms >=0 <12.2) Commands are suggestions: review each one before running it.
Loading voting…